| Service Status

What is this site?

We continuously monitor the status of our site and all related services. In the event of a service interruption, an update will be posted here. If you are experiencing problems and do not see a notice posted, please email support@mode.com for assistance.

Email delivery delays and possible failures
Incident Report for Mode
Resolved
Our third-party provider has resolved the outage and marked their incident as resolved. We expect email delivery to resume normally. Thank you for your patience.
Posted Feb 13, 2024 - 08:04 PST
Investigating
We have observed some failures with respect to email delivery that are related to an outage from our third-party provider. As a result some email deliveries may not be received immediately such as scheduled reports, invitations, or email verification. We are monitoring the provider's outage status and will update here accordingly.
Posted Feb 12, 2024 - 08:42 PST
This incident affected: Third Party Dependency.