| Service Status

What is this site?

We continuously monitor the status of our site and all related services. In the event of a service interruption, an update will be posted here. If you are experiencing problems and do not see a notice posted, please email support@mode.com for assistance.

Mode Degraded Performance
Incident Report for Mode
Resolved
This incident has been resolved.
Posted Aug 30, 2023 - 17:41 PDT
Monitoring
A fix has been implemented and we are monitoring results.
Posted Aug 30, 2023 - 16:57 PDT
Identified
Our engineering team has identified the root cause of an issue impacting performance when loading pages.
Posted Aug 30, 2023 - 16:03 PDT
This incident affected: Reports and Dashboards, Visual Explorer, and SQL Editor.