| Service Status

What is this site?

We continuously monitor the status of our site and all related services. In the event of a service interruption, an update will be posted here. If you are experiencing problems and do not see a notice posted, please email support@mode.com for assistance.

Reports with large numbers of visualizations may experience extended delays in report page load time
Incident Report for Mode
Resolved
We have implemented some performance optimizations and have observed an improvement. Customers may notice some reports with a high number of visualizations (80+) taking longer than usual to load. Please contact support@mode.com with details of the report(s) if you should experience any issues.
Posted Mar 16, 2023 - 16:42 PDT
Update
Our Engineers are continuing to investigate degraded performance in report load times for reports with large volumes of visualizations.

Our current findings indicate reports with 60-80 visualizations are slightly impacted, and reports with 80 or more visualizations are moderately impacted.
Posted Mar 16, 2023 - 14:21 PDT
Investigating
Our Engineers are aware of and actively investigating an issue where customers with large number of visualizations may experience extended delays in report page load time.
Posted Mar 16, 2023 - 11:08 PDT
This incident affected: Reports and Dashboards.