| Service Status

What is this site?

We continuously monitor the status of our site and all related services. In the event of a service interruption, an update will be posted here. If you are experiencing problems and do not see a notice posted, please email support@modeanalytics.com for assistance.

Storage System
Incident Report for ModeAnalytics
Resolved
Our S3 storage layer issues have been resolved by AWS. Our services appear to be back to normal now. We'll be keeping an extra eye on the systems for next few hours. Happy querying!
Posted 6 months ago. Feb 07, 2019 - 02:08 UTC
Update
Long time no update! The latest is the AWS S3 services team is repartitioning our data again using a different strategy based more closely on our object storage scheme.
Posted 6 months ago. Feb 07, 2019 - 00:04 UTC
Identified
Switched the status to Identified. We're still waiting for the AWS-S3 partitioning operation to complete.
Posted 6 months ago. Feb 06, 2019 - 22:38 UTC
Update
AWS tells us that they are repartitioning our data in S3 which should alleviate the problem. The process began about 20 minutes ago. They have not been able to provide an ETA to completion but they will let us know when it's done. In the mean time we'll keep posting updates here.
Posted 6 months ago. Feb 06, 2019 - 21:46 UTC
Update
AWS has identified a potential solution and is working on applying it now.
Posted 6 months ago. Feb 06, 2019 - 21:00 UTC
Update
Still working with AWS. Just wanted to let y'all know that we're still on it.
Posted 6 months ago. Feb 06, 2019 - 20:34 UTC
Update
We have escalated to AWS and are working with them to identify the issue in S3.
Posted 6 months ago. Feb 06, 2019 - 19:38 UTC
Investigating
We're seeing intermittent errors with some of our storage systems hosted in AWS on S3. We're investigating and will be escalating to AWS as needed.
Posted 6 months ago. Feb 06, 2019 - 19:09 UTC
This incident affected: Site and API.