| Service Status

What is this site?

We continuously monitor the status of our site and all related services. In the event of a service interruption, an update will be posted here. If you are experiencing problems and do not see a notice posted, please email support@mode.com for assistance.

Legacy Chart Table generates "no rows returned" when data present
Incident Report for Mode
Resolved
This incident has been resolved. Please re-run any affected reports to confirm resolution.
Posted Jun 28, 2022 - 11:07 PDT
Identified
Status as of 2022-JUN-28, 2PM EDT, 11AM PDT: Our Engineers have pushed a fix to resolve the issue. Please re-run any affected reports to confirm resolution.

Status as of 2022-JUN-28, 11AM EDT, 8AM PDT: The issue has been identified and our Engineers are working on a fix.

At roughly 6PM EDT on Monday, June 27th, two clients alerted us of Report Builder behavior where some charts incorrectly rendered, "No rows returned," error when data was present. Our Engineers identified and confirmed the issue and began actively working on it. At roughly 8:30PM EDT Monday, a third client confirmed the issue, and we escalated the behavior to an incident.

There are four workarounds available:
1. Users may view the results to view the data.
2. Users may convert their legacy Table charts to Quick Chart: Tables.
3. Users may download the results and view the CSV.
4. Users with edit access may run the SQL Report's underlying queries to validate data exists.

We recommend the second solution, but all are viable at this time.

Thank you for your patience.

Edit: The first incident post indicated the first incidents occurred at roughly 7PM. The incidents were reported to us at at 5:40PM and 6PM respectively. The Status Page has been updated to refine the initial reported time's accuracy.
Posted Jun 27, 2022 - 18:35 PDT
This incident affected: Report Run Scheduler.