| Service Status

What is this site?

We continuously monitor the status of our site and all related services. In the event of a service interruption, an update will be posted here. If you are experiencing problems and do not see a notice posted, please email support@mode.com for assistance.

Missing email deliveries for some users
Incident Report for Mode
Resolved
This incident has been resolved.
Posted Jul 30, 2024 - 11:49 PDT
Investigating
We are actively investigating an issue regarding some emails not being delivered to users as of July 29th. If you suspect you may be impacted please reach out to Support (support@mode.com) for assistance.
Posted Jul 30, 2024 - 11:28 PDT
This incident affected: Report Run Scheduler.